Fullscreen problem

nobody wrote on Wednesday, March 07, 2007:

I just port my code from win32api to GLFW and It work pretty well in window mode.

But when i try fullscreen mode the there are lots of scanlines / flicker when the scene is moving . Sometime I even see the desktop background overlapped withmy own scene (very nice effect ^_^)

can someone tell me how to fix this ?

this is the code i use to initialize window




if( !glfwOpenWindow( 1024,768, 8,8,8,8,24,0, GLFW_FULLSCREEN) )
return 0;


after this my own code set viewport to 1024 * 768 and start calling rendering in an infinite loop. I also tried to use force vsynce( glfwSwapInterval(1) ) and various refresh rate (from setting in control panel and using glfwOpenHint before create window)

I have set vsynce in nvidia control panel to “application control” but it still don’t work.

Is it have something to do with calling rendering code in an infinite loop ?, Since in win32api I use Message loop-implementation method.

If I cant use GLFW for it Windowing,can I use its other function (keyboard / joystick / timer) with my own create windows ?

I just port my keyboard / joystick code from directX to GLFW and it look 1000 time cleaner.I really don’t want to go back to win32api/directX anymore

Thank in advance


elmindreda wrote on Friday, March 16, 2007:

It seems like you’re trying to call glfwSwapInterval before you have an open window. This will not have any effect. You need to call it after you have opened a window.