Compilied GLFW failed on centOS

I install a virtual centos system on my win7’s vmware tools. all the necessary tools were installed before, like cmake,gcc,g++ and more.
but when I run : cmake .
I got the error like this:

[root@MiWiFi-R2D-srv glfw-build]# cmake .
– The C compiler identification is GNU 4.4.7
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Detecting C compile features
– Detecting C compile features - done
– Could NOT find Vulkan (missing: VULKAN_LIBRARY VULKAN_INCLUDE_DIR)
– Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE)
– Using X11 for window creation
CMake Error at /usr/local/share/cmake-3.6/Modules/FindX11.cmake:439 (message):
Could not find X11
Call Stack (most recent call first):
CMakeLists.txt:192 (find_package)

– Configuring incomplete, errors occurred!
See also “/workspace/package/glfw-3.2/glfw-build/CMakeFiles/CMakeOutput.log”.
See also “/workspace/package/glfw-3.2/glfw-build/CMakeFiles/CMakeError.log”.

But I think I already installed the x11

So what’s the problem?

Can you try running yum groupinstall "X Software Development" to install X development libraries? Maybe some of them are not installed.

yeah,I will try. I tried to run " cmake . " in windows ,cygwin. and I got the same problem: Could Not Find X11.