CMake Error: The Xinerama library and headers were not found


I’ve just downloaded glfw-3.2.1 and tried to do:

But all I got was
CMake Error at CMakeLists.txt:231 (message):
The Xinerama library and headers were not found

I installed sdl2 and libxinerama via anaconda by:

conda install -c conda-forge sdl2
conda install -c conda-forge xorg-xineramaproto
conda install -c anaconda libxinerama-devel-cos6-x86_64

How could I fix this?

Thanks in advance!!

I’m not familiar with conda as a package manager, but the main package for compiling GLFW on Ubuntu for X11 is normally xorg-dev.

Thanks a lot for your reply!!

I installed xorg-dev by sudo apt-get install xorg-dev, but it still gives the same error…

Does this error come from using Virtual Machine??

This has nothing to do with Virtual Machine.

This is an issue with your installed packages on your Linux. You need to figure out how to install correct xinerama development libraries so cmake can find them. I believe it is doing it with help of pkg-config.

No idea about conda, but try installing libxinerama-dev with apt. It should provide necessary development files for xinerama:

Thanks a lot!!

I did sudo apt-get install libxinerama-dev but it still does not work??

But I made it by conda install …