Something wrong in OSX

hesheit wrote on Tuesday, October 08, 2013:

Hi all,
I’m so frustrated with using Opengl 3.2. + GLSL 150 in Mac OSX with Intel HD Graphics 3000. I try to simulate fluid by using render-to-texture technique. I use GLFW for creating the opengl 3.2. window and GLEW for using Opengl 3.2. core functions.

In OSX, the program runs perfectly without an error, but there is something wrong. The fluid didn’t flow (it doesn’t mean the program crashes, opengl can render the fluid). Everything in the scene is motionless, Actually, the fluid should have flowed.

When I use the same code in Windows, The program runs perfectly without an error like OSX, but the fluid can FLOWS into the scene. I don’t know what’s happened.
Million thanks in advance.

dougbinks wrote on Tuesday, October 08, 2013:

If your OpenGL window is open and the back buffer has the correct settings, then GLFW is unlikely to be the problem as it only handles Input, Window interaction and OpenGL context creation.

There are substantial differences between the OpenGL capabilities of hardware on Windows versus Mac OS X due to the drivers being different, and from different sources. Apple makes the Mac OS X drivers, and each IHV makes the ones on Windows. It’s thus likely that your problem lies with an OpenGL difference between the two. I find GLView a good tool for looking at the different capabilities, though be aware that there are subtle issues which can be a problem - for example on Windows Geometry shaders run on hardware on the HD3000 but the last Apple drivers I tried ran them on software.

hesheit wrote on Tuesday, October 08, 2013:

Thank you for your response.

I already fixed it by changing the opengl context version to 2.1.
It seems opengl 3.2. core profile doesn’t provide the complete opengl functions supported on OSX.