Blank window until manually moved or resized

Hi everyone!

This is the first time I try GLFW for a quick project and I must say I’m certainly a noob. However, a problem is driving me crazy.

It happens to me that when a simple plain GLFW window opens it’s always empty, or blank. It only starts rendering the actual clear color, or whatever graphics I would want to show, when I move or resize the window itself. It happens every time I run the code.

I’m developing on a MacBook Pro 2017 with XCode 10 and Mojave, using the latest GLFW sources on GitHub, and I’ve tried multiple code snippets from different pages, but the problem is always there, even with the simplest clean window & context creation.

I haven’t been able to find any documentation or similar cases on the Internet and that’s why I’ve come here for help or moral support. Any idea on this?

I can provide you some code, but I think it’s useless as I’ve tried multiple examples out there.

Thank you very much!

I am hearing reports on Twitter that there are problems with OpenGL and OS X Mojave when using the latest SDK, but using an older one appears to work. This could be due to OpenGL being deprecated now on OS X. I don’t have Mojave installed yet, but it might be worth submitting an issue on the GLFW Github tracker.


Yep, that’s probably the reason! I’ve dived a bit into the issue tracker and found this:, which is basically the same problem.

Thank you very much for pointing me to the right direction!

1 Like