Joystick under ubuntu 10.04

cameronking wrote on Friday, August 27, 2010:


My system is Macbook Pro with Ubuntu 10.04.

I noticed that when I try to look up a connected joypad, I get nothing, Its a
standard non-flashy 10-button Logitech Precision joypad.

Using the jstest utility I found that I could access my joypad on the console:

jstest -normal /dev/input/js1

(There is a js0 and a js1 in the /dev/input but js1 accesses it.)

I get full information from the system about the USB joypad.

In GLFW I attempt to ascertain the axes, but it returns 0.

int axes = glfwGetJoystickParam(GLFW_JOYSTICK_1, GLFW_AXES);

I also tried GLFW_JOYSTICK_2 and 3. Are joysticks in Linux still ropey?



dalfy wrote on Friday, August 27, 2010:

Have you tried any of the tests and examples that uses joystick I think there
is one if not two.

Please try them and tell us what the results are.

cameronking wrote on Friday, August 27, 2010:

Checked out the Tests (I was looking under examples :-/ ) , yes all looks

I’ll go see what I did wrong.