Issue with raw mouse motion

I have enabled raw mouse motion via:

glfwSetInputMode(this->glfwWindow, GLFW_CURSOR, GLFW_CURSOR_DISABLED);
				glfwSetInputMode(this->glfwWindow, GLFW_RAW_MOUSE_MOTION, GLFW_TRUE);

And it works great on 2/3 machines I have run my application on. However, the third it does not seem to have an effect. I verified that it is supported via:


And the command returns true, but it’s clearly visible that it is not functioning as expected. I was just curious if anyone might have any recommendations or ideas on how I might better trouble shoot this?

What is the issue you are seeing?

First I would check the GLFW test cursor.c which can be set to disabled cursor with D and then raw mouse with R. This would be best done with latest code form Github.

For further debugging, this depends on the platform. On Windows I would put breakpoints in the WM_INPUT handling code:

If you still have issues, or if you think you’ve found a problem with GLFW, let us know here.



What is the issue you are seeing?

I’ve got an FPS camera setup where the mouse controls camera pitch/yaw. For the longest time I was running into an issue where when moving the mouse the screen would appear to skip frames. It was then pointed out that I needed to enable RAW_MOUSE_MOTION to insure I was receiving mouse position unaltered by windows. After doing this it completely solved the issue (for 2/3 machines). When testing on the third machine, the issue persists and RAW_MOUSE_MOTION does not seem to make a difference (as I get the same results with it enabled as I do with it disabled on this machine).

I will do some testing with the cursor.c example as you suggested and report back my findings. Greatly appreciate the suggestions!

After compiling and running the cursor test application, I did confirm that the behavior was not affected by enabling/disabling raw mouse motion for this machine. However, testing on another machine it worked exactly as expected. I then got the idea to load up half-life on this machine to see if I would experience the same issue in-game…and I did. Therefore this issue has nothing to do with GLFW, but some oddity with this specific machine. Thinking maybe the usb drivers may somehow be causing this (as i’ve tried multiple mice to no avail). It’s definitely strange.