GLFW with openGL 1.1

Hi. I am new in GLFW. I want to use GLFW in my program. I have created a program and it runs correctly but when I run that program in a machine with OpenGL 1.1, It couldn’t create window and always return null. I should run my program in that machine so how can i run it in OpenGL 1.1?

OpenGL 1.1 is rather old, and the only situation I have seen this is when no graphics hardware drivers have been installed on Windows. It might be worth checking to see if the machine has had it’s drivers installed correctly.

Do you have any more information about the Operating System and hardware this occurred on?

My machine is a server without any graphics hardware. so is it possible run my program in that machine?

You can use software implementation of OpenGL. It won’t be fast, but it will at least run.

mesa3d is one example of software GL implementation - If I’m not mistaken it will give you 3.3 version. Build instructions here: Make sure you build llvmpipe or swr backend, those are the faster ones over default softwpipe.

If you are OK with OpenGL ES, then in addition to mesa3d you can try using also SwiftShader: