Error in compiling under mingw32

nobody wrote on Sunday, November 28, 2004:

I’ve tried every which way I can to compile glfw 2.4.2 under XP using mingw32 and I’ve finally gotten down to this error:

make: *** no rule to make target `…\\enable.c’, needed by `enable.o’. Stop

is the gist of it. Something missing from a Makefile?

marcus256 wrote on Monday, November 29, 2004:

Are you using MSYS or the usual Command prompt? Are you using the standrad MinGW make program or the MSYS one?

nobody wrote on Sunday, February 20, 2005:

I’m experiencing the same error.

nobody wrote on Wednesday, April 13, 2005:

The solution is simple: (BTW, you don’t need to use the command line of windows as the documentation says, just use ‘make -f Makefile.win32.mgw’)

Change all ocurrences of ‘\’ in the Makefile to ‘/’ as usual for Unix paths. Then it runs without any problem :slight_smile:


marcus256 wrote on Sunday, April 17, 2005:

I guess I should upgrade to the latest MinGW release. It’s been a while.

Also, I know that there are some problems with the MinGW make program and Windows 9x/Me (${MAKE} becomes "C:/MinGW/bin/make.exe", for instance - note the forward slashes, which Windows does not understand).

nobody wrote on Sunday, April 24, 2005:

Im havng the same problem but I did change the "\" in the Makefile to "/" yet it displays this error:

mingw32-make: *** No rule to make target `…/enable.c’, needed by `enable.o’. Stop.
Any ideas?