Locked at 30fps when rendering with NVidia GPU (Windows 10)


#1

I recently recompiled GLFW with the GLFW_USE_HYBRID_HPG flag to automatically select my NVidia GPU instead of Intel Integrated Graphics on Windows 10; this has caused my frame rate to be locked at 30Hz, even when I’m rendering a blank scene. Not seeing this on Mac, and glfwSwapInterval does nothing. Any advice would be wonderful, thanks.


#2

Have you checked whether the NVIDIA control panel has a locked vsync?


#3

It did not, it had “Use application setting”. However, I disabled it and then reset it to that setting, and now I can successfully turn VSync on/off and when it’s on it locks to 60fps instead of 30. Maybe Nvidia was being weird behind the scenes, thanks for setting me on the right track at least!


#4

Ok sorry, I’m a bit confused again. I can’t replicate my fix from yesterday, frame rate is locked to 30Hz despite turning off vsync in Nvidia control panel. This is a real inconvenience that my GPU can’t handle something so simple.


#5

Swap intervals / VSync can be a difficult area due to driver issues, particularly on hybrid GPU systems.

It’s worth checking what frame rate you get in any of the GLFW examples to see if these share the problem (you can use a tool like FRAPS to check the framerate).